Tuesday, November 15, 2016

"Fix" Gigabyte Motherboards That Seem to Be Dead on Arrival

I like Gigabyte motherboards. I had just about all other brands of motherboards failing on me before, but never Gigabyte motherboards.

So naturally, the last few times when I decided to upgrade my desktop computers, I decided to go with Gigabyte motherboards.

Unfortunately, now the X99 chipset based Gigabyte motherboards appeared to be dead on arrival each time.

The first one was a GA-X99-UD3P. I bought it with an Intel i7 5820K CPU. After all the parts were put together, when the computer was powered up, the speaker connected to the motherboard would beep many times, and the machine would then power cycle itself. This would repeat over and over again. I checked the AT motherboard POST beep codes, and it seemed to indicate that the CPU was bad.

I talked to the nice folks at Microcenter, where I bought the motherboard and CPU from. They felt that it was extremely unlikely the CPU was bad, so they replaced the motherboard for me. I installed the replaced motherboard, but to my surprise, the problem was the same!

So now, it must be the CPU then. I went back to Microcenter, and had the CPU replaced.  I installed the replaced CPU, and the problem was still the same!

At this point, it was obvious that this was a compatibility issue, not faulty parts. I never expected compatibility would be a problem, since Microcenter sold the CPU and motherboard as a bundle. Why would they bundle them together if they were not compatible with each other?

I gave up, and sent my computer to Microcenter service department to take a look. Days and fifty dollars later, I got my computer back. They fixed the problem by updating the motherboard's BIOS to a later version.

I did not think anything of the solution at the time. Microcenter would have older CPUs that they could have booted the computer with, and then they could updated the BIOS.

After eleven months of use, yesterday, this computer would no longer boot. I really do not have time for a lengthy fix, so I decided to buy a new CPU and motherboard combo, and just replace both.

This time I bought an i7 6800K CPU, and an GA-X99-SLI motherboard. I thought this way, I could do a simple swap of parts, then just continue working.

Well, no such luck. After replacing the CPU and the motherboard, the computer would just keep rebooting itself. Even worse than the first upgrade, there were no AT POST beeping codes. The speaker was completely silent. I even tried using the old CPU on the new motherboard, thinking that a new 2011-v3 motherboard should be at least compatible with i7 5820K.

Well, the computer still kept rebooting itself. Although at times it seemed to be doing device scans, it never beeped or showed anything on the screen.

There must be an easier way than sending the computer to Microcenter. I googled for an answer. To my amazement, Gigabyte motherboards can be flashed even without a CPU or any RAM installed. It does not matter if there is nothing shown on the screen. Gigabyte calls it Q-Flash. Q-Flash has been around for many years, but usually you would still boot up the computer and go into the CMOS setup to use Q-Flash. I never knew that it was not really necessary to boot into the CMOS setup screen.

At the back of these Gigabyte motherboards, there is one USB port that is color coded differently than the standard blue color for USB 3. It is white-color coded. I placed the latest BIOS file on a USB drive with FAT file system, and plugged it into this port. One of the online videos I found on google said that you needed to rename the BIOS file to "Gigabyte.bin". For good measures I placed two copies of the BIOS file on the USB drive. One with its original name, and one renamed to  "Gigabyte.bin".

The LED light on the USB drive started to blink like crazy. At first the machine was still rebooting, and the LED light would go out while the computer was briefly powered off, and then continued to blink while the power came back on.

After a few cycles, the computer would then stay on, and the LED light on the USB drive would continue to blink. At the same time an LED light on the motherboard near the USB port started to blink as well. After several minutes, the LED lights then stayed on constantly. They seem to indicate that the BIOS finished updating.

After I power cycled the computer, it would still not boot up. Then I remembered that I still had the old i7 5820K in there. So I swapped it out with the new i7-6800K.

When I powered up the beast this time, it booted all the way up, and the CMOS setup screen showed on the monitor, finally.

No comments:

Post a Comment